Sorry, we don't support your browser.  Install a modern browser

Need to fix Newton Linux - Snap#678

I’ve been a subscriber to Newton almost since it’s inception, but I constantly am having issues with the linux version of the Newton Client. Please fix the snap version so that it runs on all OS’s supporting snap.

21 days ago