Sorry, we don't support your browser.  Install a modern browser

Distribute Newton as an AppImage#733

Snap packages only work on certain Linux distributions and require installation of snapd. AppImage is a simpler format that works on virtually all Linux distributions. Alternatively, Flatpak support would be great too.

3 months ago